Source / pinned edition

Date and Time on the Internet: Timestamps with Additional Information

Source of package ietf.timestamps · RFC 9557

work
urn:ietf:clir:timestamps#RFC9557
number
RFC 9557
kind
urn:ietf:clir:timestamps#standards_track

RFC 9557, April 2024

edition
urn:ietf:clir:timestamps#RFC9557_EN
language
en
officiality
official
materialisation
PINNED_OFFICIAL_BYTES
life cycle
adopted: 2024-04-01; in_force: [object Object]

Publications

URITypedocumentHashRetrieved
https://www.rfc-editor.org/rfc/rfc9557.txttext/plain; charset=us-asciisha256:87fa632cd75d13aa441859da635ed6618f66d203fe71a30fa85afedbeb149e852026-09-04T22:30:00Z

Fragments — 2

section/2_2 · section · referenced by: 2

en · official · sha256:e7b74600b1a2a5938e6f9f5c124872f4c20536a3a00d94ade07bd4a3515417ce

2.2. Update to RFC 3339 This specification updates Section 4.3 of [RFC3339], aligning it with the actual practice of interpreting the offset Z to mean the same as -00:00: "the time in UTC is known, but the offset to local time is unknown". Section 4.3 of [RFC3339] is revised to read as follows: | If the time in UTC is known, but the offset to local time is | unknown, this can be represented with an offset of "Z". (The | original version of this specification provided -00:00 for this | purpose, which is not allowed by [ISO8601:2000] and therefore is | less interoperable; Section 3.3 of [RFC5322] describes a related | convention for email, which does not have this problem). This | differs semantically from an offset of +00:00, which implies that | UTC is the preferred reference point for the specified time.

Referencing norms: OffsetMeaningIsUnique, ZuluMeansUnknownOffsetAfterRfc9557

section/2_3 · section · referenced by: 1

en · official · sha256:38a266f389f2446bbc10e7f4b5e536becbac24d3c71ec61c2adcf4aa8d3cfb21

2.3. Notes Note that the semantics of the local offset +00:00 is not updated; this retains the implication that UTC is the preferred reference point for the specified time.

Referencing norms: PositiveZeroMeansUtcPreferred

The hash beside the text is the sha256 of its exact bytes. It is the check that the text shown matches the one pinned in the package: a divergence fails the oracle’s static analysis.